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Thisdocumenthas been written as a tutoridbr processing spectra taken with an A0
spectrograph using BASIhe same approach can be used for most slit spectrograflease refer
to the BASS User Manual for more detailed information on any aspect of processing.
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Notes

This tutorial specifies how to access screens using the menus. Manymbgtecommon and useful
screens are also accessible from buttons below the menu bar.
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1 - Stackand Calibratdmages

First you need to stack individual images of the same tamyad apply image calibrations for bias,
dark and flat field. Even if yanly have 1 image of your target, then you will need to follow this
process to perform the image calibratiarfblote wavelength calibration comes later.)

You can of course perform stacking and calibration in your preferred image processing software. In
which case jump to section 2 or 3 as appiafe.

Menu: File-> Stack Images
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be applied later on.

X stack Images O ®
File Image Zoom

L@i*ﬂageﬂlﬂﬂﬂknagesl

Light Images

Vega_Os_20150820_220016-1 fit
Vega_Os_20150820_220016-2 it
Vega_Os_20150820_220016-3fi
Vega_0s_20150820_220016-4 i
Vega_0s_20150820_220016-5i
Vega_s_20150820_220016-6i
Vega_0s_20150820_220016-7 fi

¥ Use median for dark/bias.flat

[V Save masterimages
[~ Min Zero

| o o]




Next select your dark, bias and flat images.

If the exposure time of your dark frames is the same as your light images then you do not need bias
frames. Howevelincludingbias frames allows BASS to scale 1 set of dark fraon@sitch any light
exposure time.

Flat darks can improve the quality of your flat field, but they must match the exposure time of your
flat images.

If you have a master cosmetic file listing the hot pixels in your camera, then this should be selected
in the Cosmetic file box. Creating a cosmetic file is explained in the next section.

BB Stack Images O x

File  Image

Light Imzges  Other mages |

Cosmetic file

|

Dark Images
Dark image scale factor |u—

Dark_180s_20150819_232807-1F o
Dark_180s_20150819_232807-2f
Dark_180s_20150819_232807-3f

Dark_180s_20150815_232807-5F ¥

Bmimoe @]
Offset_0s_20150819_222602-17t m
Offset_Ds_20150913_222602-2t
Offset_Ds_20150919_222602-3 it
Offset_Ds_20150819_222602-4 fit
Offset_0s_20150819_222602-5t ¥

==
V' Normalise flats
Flat_10s_20150820_211212-1fit  »
Flat_10s_20150820_211212-2fit
Flat_10s_20150820_211212-3fit

Flat_10s_20150820_211212-4fi
Flat_10s_20150220_ 2112125ft ¥

FAat Dark Images ’E‘W

I
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Now press stack.




B8 BASS Project: _defaultbass - X
File Chart Selection Image Calibration Operation Tools Help

mage Siip View

HEARE RN

N

I | Profile #01 W=1391 H=1039

Change the caption of your stacked image to a sensible name, in this case Vega. To do this, simply
double click the image and then change thaption box.

This will update the legend on the plot.

B8 BASS Project: _defaultbass - b4
File Chart Selection Image Calibratien Operation  Tools

image Stip View

I
=
.
< |5~ Raw Image 50% [l

0.000 200.0 600.0 800.0
Pixels (uncalibrated)

Fmﬁ\e #01 Px: 1318 Intensity: 0.2883081 Profile #01 W=1391 H=1039

Finally saveyour image with an appropriate name
Menu:File-§ { I @S AYI3S | ax

It is good practice tinclude the object, the date and sometimd®ettime, and a description of the
processingstep, e.g. Vega_20150828tack.fit.



2 - Hot Pixel and Cosmic Ray Removal

This step is often needed to clean up the image. Without this step you may have spikes in your final
spectrum due to hot pixels or cosmic ray hits.

There are 2 approaches that can beds

1 Create a master hot pixel map from your master dark image. This grediable hot pixel
removal butwill not remove cosmic ray hitsom your stacked spectrum image

91 Detect and remove them from your stacked imagjhis approach is harder since yoavk
to avoid removing the spectrunvhich can look a bit like hot pixelBhis step is needed if
you have cosmic ray hits.

The best approach is a mix of the two methods. First apply a master hot pixel map created using
your master dark image. If you haveyatosmic ray hits, then follow up with a correction to your
stacked image to remove the cosmic rays.

To access the screen:

Menu: Image> CosmicHot & ColdPixel Removal

BH Cosmic & hot pixel removal: 01: Stack7Images m] X
Image ICUSFHB‘UC File ]
P T T T R I Region ’—H—I
Threshold 472
Bl e oy Epe

Hot Pixel detection threshold 74.72%

< >

Nohot pixels or cosmic rays detectauthis imageat the 74% threshold




a. Creatng a Hot Pixel Map

An excellent way to detect hot pixels is to wsmaster dark imageSuch an image will have been
Fdzi2YFGAOFtf& ONBI (S RSaw tasterinjagés I aA @ 2Pk inggeser@Siz o S 7T
screenAlso, you can typically use the same map for several months.

To help see the hot pixels it is a good idea to amend the black and white levels by clicking the button

4

Then adjust the black and white level to low values. Here 0 and 2500. A white leB@Cofri2ans
any pixels of 2500 ADU and above will be white, and between 0 and 2500 scaled from black to white.

B & W Levels 00: Stack7Images ﬂ
White L evel 2500
P
H i J
Y
o
Black Level 0

[~ Show Clpping ¥ CWhite/CBlack

open images

Now you can start on thkot pixel removal. djust the threshold percentage until you pick up the
majority of the hot pixels. The hatixels will be indicated by little green crosses. The threshold ADU
value will be shown when you move or hover your mouse on the slider.

B Cosmic, hot & cold pixel removal: O1: StackTImages o %
Image | Cosmetic Fie | |
n . . . . \ . . . . s
EI Threshold ADU% - }
Zoom [100% =] T RegiolHot Pixel detection threshold 045% ADU 408.164)ictect
~
Bad el st (0)
v
< >
X1025 Y18
Medan [~ Applytoal - -
¥ corection open images hand || e

A 0.45% (408 ADU) threshold has been used in the screenshot above as this picked up the hot pixels
without saturatingthe image. If this was a spectrum image then a higher percentage would be
needed to avoid removing the brighter parts of the spectrum.

Use the side bars to move around your image to check you have picked up the majority of the hot
pixels while leaving mopixels untouched.
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931 Save As

This PC Documents BASS Processing Alpy_Francais_Tuterial Search Alpy_Francois

Spectra ) Mame Date medified Type Size
[ This PC
[ Desktop

*=| Documents
4 Downloads
J\. Music

No items match your search.

&= Pictures

ﬁ Videos

2o Local Disk (&)
- Recovery (D)
- HP_TOOLS (E:)

=% Netwnrk b

Organize - Mew folder 4== -

File name:

Save as type: | List files (*.Ist)

# Hide Folders

Cancel

B8 Cosmic & hot pixel removal: 01: Stack7Images

< >

m} X

P 471011
P 3471001
P 184 589
P 1073528
P 551326
P 342 507
P 688 863
P 1076 835
P 476 809
P 135201
P 97724

P 863 717
P 15709

P 922 670
P 74 663

P 107 663
P 315619
P 1348 569
P 547537
P 1127523
P 674 509
P 110 485
P 1052 449
PE414

P 265 396
P 1284 385
P 474 361
P 344 354
P 1223323
P 341316
P 646 315
P 470 304
P 1274276
P 1331238
P 261148
P 537 117
P 1202112
P 62963

P 128561
P 206 52

A

v
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This hot pixel map can be applied to your stacked image by pressing the Apply button.
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i K Stack Images
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B stack Images
File Image Zoom

Light Images Dﬂ’ﬂhagsl

Cosmetic file @

g\Alpy_Francois_Titorial'\cosmatic st

Derkcimages (1) [ 1 |
Dark image scale factor lu—

Dark_180s_20150819_232807-1f &

Dark_180s_20150819_232807-5f ¥

Bias images (0) EI

Offset_Os_20150819_222602-1fit A

Offset_0s_20150819_222602-5fit ¥

Hat images (7) El

W Nomalise fizts

Flat_10s_20150820 211212-1fit A
Flat_10s_20150820_211212-2fit
Flat_10s_20150820_211212-3fit
Flat_10s_20150820_211212-4fit
Flat_10s_20150820_211212-5fit v

Aat Dark images (0) El
—

| St=cling Completed

Stack. Close ‘ Size w:1391 h:1039
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b. Cosmic & Hot Pixel Removal from a Spectrum

Note a hot pixel map would not remove cosmic ray hits as they happen on sirages. If you have
cosmic ray hits then you must remove them by running thentlo, Hot & Cold Pixel Removal.

4

As before adjust the black and white levels using the bu—=!, s that the spectrumand any
cosmic rays and hot pixels loakce and clear

B & W Levels 00: Stack9images [ = |
White Level 30500
[
J
N
i
Black Level -2000
I~ Show Clipping [

open images

Adjust thethresholdslideruntil you remove the cosmic ray hits or hot pixels, iithout removing
any of the spectrum. This can be tricky ensure you take your time and be careliuls very
important not to remove any bright parts of the spectrum igeawhen removing hot pixels and
cosmic rays.

B8 Cosmic, hot & cold pixel removal: 01: GamPeg-1.fit =, X
mage | Cosmetic Fie |
' . . . . . . . . . '
@ Threshold ADU%  —— '} 365
Zoom |100% v I Region of interest I Cold pixels I Edge detect
Bad pixel list (0)

< >

X:949 Y:874
Median Apply to all
7 o B [ ]

No clear cosmic ray hits were seen in the sample images for this tutorial. So instead a high resolution
spectrum taken with an Lhires |1l with plenty of hot pixels is shown above.
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3 - Geomadric Correctiors

The geometric corrections must be applied to both your stellar images (stacked) and neon or other
emission line calibration images at the same ti¢herwise the geometry of your wavelength
calibration image and star images will be out of syFiuis will cause your wavelength calibration to
vary with vertical position in the image and therefore be wrong.

If you are using a slit spectrograph but are not using a wavelength calibration lamp, then you can use
a street light or similar spectrum witmission lines to perform the Smile / Slant correction.

Make sure you havall your different stacked stellagpectrum images and your wavelength
calibration imagde.g.Neon line spectrumopen in BASS

¢KS LYIFI3S {GNRAL) +ABYlI AR2d0R HbE BSHISHDSYwWFES (KL G
level of detail.
It is advisable to apply the geometric corrections in the following order:

1 Rotate / Tilt Correction
2 Smile / Slant Correction

This is because the rotatidrilt adjustment will chang the slant angle, but the slant will not change
the tilt.

11



a. Rotate / Tilt Correction

Click on one of your star images so that this image is now selected, border turns yellow.
Make sure that the black and white levels are set such that the spectrum irmatgar.

Menu: Image> Black & White Levels

B & W Levels 01: Stack7lmages n

White Level 3500

j —

1

Black Level 2000 |
[ Show Clipping v CWhite/CBlack
Auto Stretch [~ Apply levels all Ok Cancel
open images

Do not worry if you have some negative pixel values. This is caused by random noise in dark current
and bias.

To make your spectrum perfectly horizontal we use the following menu screen.
Menu: Image> Rotatef Tilt correction

Ensure apply to all open images is ticked

Rotate / Tilt: 02 Stack/lmages n

Rotate / Tilt l Horizontal Smile

Comection Angle
010 =

Select Option
" Rotate Image

Centre XY

* Titt Image

" Draw Angle
{* Select Region

¥ Emission I¥ Applyto all open images

Aoply Close
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Draw a rectangle around your spectrum image.

B8 BASS Project: _default.bass
File Chart Selection Image Calibration Operation Tools Help

Rotate / Tikt I Horizortal Smile

Comection Angle
" Draw Angle

010 &+ Select Region

Select Option
" Rotate Image
Centre XY

&+ Tit Image

W Emission ¥ Appiy to all open images

Titt Calc Complete Profile #02 W=1351 H=1033
Click Apply.
Check that the correction looks sensible, i.e. you now have a horizontal spectrum.

If it looks wrong then press reset and try again.
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b. Smile / Slant Correction

Makethe neon image the first image by right clicking the image, select Sequence, then 01.

[P BASS Project: _default.bass - X

File Chart Selection Image Calibration Operation Tools Help

Profile #01 W=1391 H=1039 Dispersion: 1.00000001 A/px

Menu: Image> Smile / Slant Correction
al 1S &a4dz2NB GKS a! LJSe G2 Ffft 2Ly AYlF3IASa¢ed Aa GAao0]
Choose a nice bright calibration limegt too close to any edges, and draw a rectangle around the

line. Keep the selection height within the emission line (or the ends will add noise to the

calculations).

[P BASS Project: _default.bass - X

File Chart Selection Image Calibration Qperation Tools Help

Auto Smile/Siant | Manual Smile / Stant |

Select a region on the image containing
avertical line or feature to straighten

I Full height selection
Pixels Average |1 -

Regresson  [jnone] -

¥ Emission ¥ Apply to all open images

(o] o [ o=

Smile Comection complete Profile #01 W=1391 H=1039 Dispersion: 1.00000001 A/px

14



{Si GKS NBINBaarzy (2 [AYSINIFYR GKSYy LINBaa dac¢NE

Smile/Slant: 01 Calib_15s_20150820_211026-1 fit [« |

Auta Smile/Slant | Manual Smile / Slant

Select a region on the image containing
awvertical line or feature to straighten

[ Full height selection

Picels Average | 1 j

Regression ||Jnear ﬂ

|1 15 deagrees

¥ Emission [ Applyto all open images

Try Apply ‘ Close

If the bright red line followsgqur emission line then great. Otherwise try adjusting the Pixel Average
FYR wSaANBaaiAzy LI NI Y SRepdafinti yoki Baye alghodbfia ¢ NBE | I AY

Senile/Slant: 01 Calib_15s_20150820_211026-1 fit n

Auto Smile/Slant | Manual Smile / Slant

Select a region on the image containing
avertical line or feature to straighten

[ Full height selection

Picels Average | 1 ﬂ

Regression |Quad|ati|: (2nd degree] j

v  Emission W Applyto all open images

Try Apply ‘ Close

When happyagain make sure th¢/! LILJ & (2 | €heckbdxslfcked dndthed frésS
Appl.
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You should now have nice straight and vertical emission lines, noting this will also have been applied
to your spectrum image.

[BH BASS Project: _default.bass - X
File Chart Selection Image Calibration Operation Tools Help

: ——= Image Strip View 73 x r
] g, | W |7« |1 = 7 I B

Profile #01 W=1391 H=1039 Dispersion: 1.00000001 A/px

If you are happy with these results then now save both your neon and stellar images, giving them a
different name, e.gBRRAY 3 ayp3S2¢ (2 (GKS SyRo®
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4 - Select Binning Regions

Make sure your star spectrum image is selected, click on it if necessary. A yellow border shows it is
selected.

Enlarge the image so you have a clear and detailed view of a good part of your star sgetgen
¢tKS 1T22Y tS@St Aa OKFIy3aSR Ay GKS aLYF3IS {GNRLI £A

Adjust the black and white levels so that the spectrum image appears bright and you can see the
faintest parts of the spectrum image easily. Do not worry abovesgieetrum looking over exposed.

Menu: Image> Black & White Levels

17






































































































