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This document has been written as a tutorial for processing spectra taken with an Alpy 600 

spectrograph using BASS. The same approach can be used for most slit spectrographs. Please refer 

to the BASS User Manual for more detailed information on any aspect of processing. 

Acknowledgement of Sample Spectra 

The spectra used in this tutorial were obtained from François Cochard of Shelyak Instruments during 

the BAA Alpy Workshop in 2016. 

Notes 

This tutorial specifies how to access screens using the menus. Many of the most common and useful 

screens are also accessible from buttons below the menu bar. 

  

http://www.shelyak.com/
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1 - Stack and Calibrate Images 

First you need to stack individual images of the same target, and apply image calibrations for bias, 

dark and flat field. Even if you only have 1 image of your target, then you will need to follow this 

process to perform the image calibrations. (Note wavelength calibration comes later.) 

You can of course perform stacking and calibration in your preferred image processing software. In 

which case jump to section 2 or 3 as appropriate. 

 

Menu: File -> Stack Images 

First select your “Light Images”. These are the images of your target star spectrum. 

Ensure that “no alignment” is selected. Any alignment would invalidate the geometric corrections to 

be applied later on. 
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Next select your dark, bias and flat images. 

If the exposure time of your dark frames is the same as your light images then you do not need bias 

frames. However, including bias frames allows BASS to scale 1 set of dark frames to match any light 

exposure time. 

Flat darks can improve the quality of your flat field, but they must match the exposure time of your 

flat images. 

If you have a master cosmetic file listing the hot pixels in your camera, then this should be selected 

in the Cosmetic file box. Creating a cosmetic file is explained in the next section. 

 

Now press stack. 
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Change the caption of your stacked image to a sensible name, in this case Vega. To do this, simply 

double click the image and then change the Caption box. 

This will update the legend on the plot. 

 

Finally save your image with an appropriate name. 

Menu: File -> Save image as… 

It is good practice to include the object, the date and sometimes the time, and a description of the 

processing step, e.g. Vega_20150820_Stack.fit. 
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2 - Hot Pixel and Cosmic Ray Removal 

This step is often needed to clean up the image. Without this step you may have spikes in your final 

spectrum due to hot pixels or cosmic ray hits. 

There are 2 approaches that can be used: 

• Create a master hot pixel map from your master dark image. This gives a reliable hot pixel 

removal but will not remove cosmic ray hits from your stacked spectrum image. 

• Detect and remove them from your stacked image. This approach is harder since you have 

to avoid removing the spectrum which can look a bit like hot pixels. This step is needed if 

you have cosmic ray hits. 

The best approach is a mix of the two methods. First apply a master hot pixel map created using 

your master dark image. If you have any cosmic ray hits, then follow up with a correction to your 

stacked image to remove the cosmic rays. 

 

To access the screen: 

Menu: Image -> Cosmic, Hot & Cold Pixel Removal 

 

No hot pixels or cosmic rays detected in this image at the 74% threshold. 
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a. Creating a Hot Pixel Map 

An excellent way to detect hot pixels is to use a master dark image. Such an image will have been 

automatically created by BASS as long as you left “Save master images” ticked in the “Stack images” 

screen. Also, you can typically use the same map for several months. 

To help see the hot pixels it is a good idea to amend the black and white levels by clicking the button 

 

Then adjust the black and white level to low values. Here 0 and 2500. A white level of 2500 means 

any pixels of 2500 ADU and above will be white, and between 0 and 2500 scaled from black to white. 

 

Now you can start on the hot pixel removal. Adjust the threshold percentage until you pick up the 

majority of the hot pixels. The hot pixels will be indicated by little green crosses. The threshold ADU 

value will be shown when you move or hover your mouse on the slider. 

 

A 0.45% (408 ADU) threshold has been used in the screenshot above as this picked up the hot pixels 

without saturating the image. If this was a spectrum image then a higher percentage would be 

needed to avoid removing the brighter parts of the spectrum. 

Use the side bars to move around your image to check you have picked up the majority of the hot 

pixels while leaving most pixels untouched.
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Click the “Cosmetic File” tab and press save to create a master file listing your hot pixels. A good 

filename would be “cosmetic.lst”. 

 

 

This hot pixel map can be applied to your stacked image by pressing the Apply button. 

  



9 
 

You can also use it in future processing by selecting the “Cosmetic File” on the “Other Images” tab of 

the “Stack Images” screen. 
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b. Cosmic & Hot Pixel Removal from a Spectrum 

Note a hot pixel map would not remove cosmic ray hits as they happen on single images. If you have 

cosmic ray hits then you must remove them by running the Cosmic, Hot & Cold Pixel Removal. 

As before adjust the black and white levels using the button , so that the spectrum and any 

cosmic rays and hot pixels look nice and clear. 

 

Adjust the threshold slider until you remove the cosmic ray hits or hot pixels, but without removing 

any of the spectrum. This can be tricky, so ensure you take your time and be careful. It is very 

important not to remove any bright parts of the spectrum image when removing hot pixels and 

cosmic rays. 

 

No clear cosmic ray hits were seen in the sample images for this tutorial. So instead a high resolution 

spectrum taken with an Lhires III with plenty of hot pixels is shown above. 
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3 - Geometric Corrections 

The geometric corrections must be applied to both your stellar images (stacked) and neon or other 

emission line calibration images at the same time. Otherwise the geometry of your wavelength 

calibration image and star images will be out of sync. This will cause your wavelength calibration to 

vary with vertical position in the image and therefore be wrong. 

If you are using a slit spectrograph but are not using a wavelength calibration lamp, then you can use 

a street light or similar spectrum with emission lines to perform the Smile / Slant correction. 

Make sure you have all your different stacked stellar spectrum images and your wavelength 

calibration image (e.g. Neon line spectrum) open in BASS. 

The Image Strip View should be set to “Raw Image ..” at a percentage that enables you to see a good 

level of detail. 

It is advisable to apply the geometric corrections in the following order: 

1 Rotate / Tilt Correction 

2 Smile / Slant Correction 

This is because the rotation / tilt adjustment will change the slant angle, but the slant will not change 

the tilt. 
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a. Rotate / Tilt Correction 

Click on one of your star images so that this image is now selected, border turns yellow. 

Make sure that the black and white levels are set such that the spectrum image is clear. 

Menu: Image -> Black & White Levels 

 

Do not worry if you have some negative pixel values. This is caused by random noise in dark current 

and bias. 

To make your spectrum perfectly horizontal we use the following menu screen. 

Menu: Image -> Rotate / Tilt correction 

Ensure apply to all open images is ticked 
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Draw a rectangle around your spectrum image. 

 

Click Apply. 

Check that the correction looks sensible, i.e. you now have a horizontal spectrum. 

If it looks wrong then press reset and try again. 
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b. Smile / Slant Correction 

Make the neon image the first image by right clicking the image, select Sequence, then 01. 

 

Menu: Image -> Smile / Slant Correction 

Make sure the “Apply to all open images” is ticked. 

Choose a nice bright calibration line, not too close to any edges, and draw a rectangle around the 

line. Keep the selection height within the emission line (or the ends will add noise to the 

calculations). 
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Set the regression to Linear and then press “Try”. 

 

If the bright red line follows your emission line then great. Otherwise try adjusting the Pixel Average 

and Regression parameters then press “Try” again. Repeat until you have a good fit. 

 

When happy, again make sure the ‘Apply to all open images’ checkbox is ticked, and then press 

Apply.  
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You should now have nice straight and vertical emission lines, noting this will also have been applied 

to your spectrum image. 

 

If you are happy with these results then now save both your neon and stellar images, giving them a 

different name, e.g. adding “_geo” to the end.  
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4 - Select Binning Regions 

Make sure your star spectrum image is selected, click on it if necessary. A yellow border shows it is 

selected. 

Enlarge the image so you have a clear and detailed view of a good part of your star spectrum image. 

The zoom level is changed in the “Image Strip View” in the top centre of the screen. 

Adjust the black and white levels so that the spectrum image appears bright and you can see the 

faintest parts of the spectrum image easily. Do not worry above the spectrum looking over exposed. 

Menu: Image -> Black & White Levels 
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Draw a rectangle around part of the spectrum. It does not need to be wide. What matters is that the 

top and bottom parts of the spectrum are fully enclosed, and as little background as possible is 

included. Note that your spectrum will often contain faint tails above and below the main bright 

horizontal line. It is important to include these tails. 

 

Then select the following menu item. 

Menu: Selection -> Select Active Binning Region 

 

Green lines will now appear above and below the spectrum. The region between these lines will be 

used to sum up the pixels and give you your spectrum. 
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Now select a rectangular region above your spectrum for the sky background. This should be away 

from your stellar spectrum and avoid any other obvious feature so you are just picking up sky 

emission. 

 

Menu: Selection -> Set Active Subtraction Region 1 

 

2 pink lines will now appear above the spectrum. Pixels between these lines will be used for the sky 

background subtraction. 
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We need to do the same below the spectrum. So select a rectangle below your spectrum image. 

 

Menu: Selection -> Set Active Subtraction Region 2 

 

Now 2 pink lines will appear below your spectrum. 
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You can now reset the zoom and black and white levels. 
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We need to copy the same binning regions to the neon calibration image. 

Select your neon calibration image so it is highlighted with a yellow border. 

Right click the image and select copy active binning region from and then the star spectrum image 

on which you set the active binning region. 

 

The green lines will appear on your neon spectrum matching the active binning region from your star 

image. 
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5 - Wavelength Calibration 

This can be surprisingly difficult at low resolution due to the large number of lines that may be 

shown in your neon or other wavelength calibration spectrum. For example the Alpy module may 

contain lines from neon, argon and hydrogen. 

The first subsection below provides some sample low resolution spectra. These should help you to 

identify lines for wavelength calibration, and some suggested lines are given for Alpy users. 

Then then next subsection explains how to do perform wavelength using a Neon or similar emission 

line calibration lamp spectrum. 

For those who do not have a calibration lamp, the final subsection explains how to perform 

wavelength calibration using an A or B-type star. 

 

a. Sample Calibration Spectra 

Below are a few sample spectra from various websites which may help to identify the lines in your 

calibration spectrum. 

Neon spectrum from Christian Buil’s website: 

http://www.astrosurf.com/buil/us/spe2/hresol4.htm 

 

http://www.astrosurf.com/buil/us/spe2/hresol4.htm
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From the Alpy user guide. 

 

 

Image from Christian Buil’s website. 

http://www.astrosurf.com/buil/alpy600/first_light.htm 

 

 

 

 

 

http://www.astrosurf.com/buil/alpy600/first_light.htm
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I found the following lines worked well for the Alpy calibration spectrum from François Cochard. 

Note that calibration lamps may vary so find what works best for your setup. 

• 4200.67 Ar 

• 4764.87 Ar 

• 5852.49 Ne 

• 6562.85 Hα 

• 6965.43 Ar 

• 7272.94 Ar 
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b. Wavelength Calibration Process 

Make sure your neon calibration image is selected. 

The calibration image needs to be the first image. If it is not then right click the image, select 

Sequence and then 01. 

 

Scroll down to the graph area of the screen, as all selections will be done on the lines on the graph. 

To enter calibration mode select the following menu item. 

Menu: Calibration -> Create/Edit Calibration 

Now select a nice bright neon line on the left of the screen. 
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Then either select an element filter or type in the wavelength for the line. 

Note that for convenience I’ve added the list of 6 Alpy lines I am use to the CalibLines.dat file. This 

file can be found in the ..\BASS Project\Reference folder. 

 

Click Add Another Point. 

Select another bright line which you can identify. 

Continue until you have 5-7 lines, checking that the error remains small for each new line. A very 

large error on one line may indicate that it has been mis-identified. 
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The below screenshot illustrates the error I was getting with 6 lines and a linear fit. 

 

 

Adjusting the calibration fit to “3 Cubic” gives a much better fit. 
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It may be possible to improve on the fit by choosing more or better lines, or by increasing the 

polynomial of the calibration fit. However be careful. Choosing a high order polynomial of 1 below 

your number of calibration points or higher will always give a perfect fit. This is misleading as you are 

simply fitting the number of free parameters in the polynomial to your number of data points. Even 

if you pick a completely wrong line the fit will remain perfect. Therefore avoid very high order 

polynomials unless you have good reason to believe they give a true fit to your wavelength 

calibration. 

You can then set the Image Strip View to Synth Colour (Stretch) to show your spectra in colour. 
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To copy the calibration parameters onto the target spectrum, double click the target star image. 

Select the Calibration tab. 

Then press Copy. 

 

 

Save your images. 
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c. Wavelength Calibration with an A or B-Type Star 

If you do not have a calibration lamp to wavelength calibrate your spectrum, then it is possible to 

use the hydrogen lines from an A or a B-type star. 

To do this you will need to have taken an image of the spectrum of an A or a B-type star, with your 

equipment in exactly the same configuration as when you took all of your target star spectra on the 

same night. You should pick a bright A or B-type star with clear hydrogen absorption lines. So you 

want an ordinary star. Vega is ideal when it is visible. You will need to easily see absorption lines 

from H-alpha to at least H-delta or further. 

Note the basic process is the same as if you were using a calibration lamp.  

 

Make sure your A or B-type star image is the first image. 

Right click image -> Sequence 

 

Also make sure that your A or B-type star image is selected. 

Scroll down to the graph area of the screen, as all selections will be done on the lines on the graph. 
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To enter calibration mode select the following menu item. 

Menu: Calibration -> Create/Edit Calibration 

It is easiest to start by selecting H-alpha, the rightmost hydrogen line. This is done by placing the 

cursor just left of the line on the graph, dragging over to the right of the line and then releasing. 

 

Select Hydrogen from the Element filter and Hα from the wavelength drop down. 
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The click Add Another Point and repeat for as many clear hydrogen lines are visible. 

At first with a linear fit the errors will be large. 

 

 

Changing to a Quadratic or Cubic will give a better result. 
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You will now have a well calibrated spectrum, though you should be cautious of the wavelengths 

below the shortest calibration point and above the longest wavelength calibration point. 

You can get now get a colour view of your spectrum image strips by changing the Image Strip View 

to Synth Colour (stretch). 
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To copy the calibration to another star, then double click the image strip for that star. 

Select the Calibration tab. 

 

Then press Copy to copy the calibration from the first profile. 
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6 - Response Correction (Advanced) 

Normally an A or a B type star is used to obtain the response correction as they are very simple 

spectra dominated by absorption due to the hydrogen Balmer lines. This response correction curve 

can then be applied to other stars at a similar altitude on the same night. 

What we are after is a curve that will correct for the effects of your instrumentation and the Earth’s 

atmosphere. By applying this curve your spectrum will be corrected to show the actual stellar 

spectrum, noting this will often differ from the perfect spectral type. 

You should avoid response correcting each target star spectrum separately using a template 

spectrum that matches its spectral type. This is because you would always get a perfect fit that 

matches the spectral type as you would be going in a processing circle forcing the spectrum to match 

whatever template you started with. This would also mean that if the star was not a perfect match 

for its spectral type, a common occurrence, then your corrected spectrum would make it look as 

though it were a perfect match. 

The below process uses the A0V star Vega to create a response curve, and then confirm this has 

worked by comparing it back to an A0V template. In scientific work this would be the first step. Next 

this response curve would be applied to your target stars other than Vega. 
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First load an appropriate standard spectrum to match the one you are working on. The ideal would 

be a Miles spectrum of the exact star but otherwise a Pickles spectrum for the spectral type. 

Note, if you use a Miles star then you must not use the spectra labelled “dered”. These are spectra 

which have been corrected for interstellar extinction and would invalidate your response curve. 

Menu: Tools -> Reference Spectrum 

If using a Miles star, then click Source and Miles. Then search for the HD number of the star. 

This example is Vega, which is not in the Miles database. So we shall select the Pickles A0V 

spectrum. 

 

Click “Add Spectrum to Chart” then close. 

 

This has added the Pickles A0V spectrum as a third profile. 
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The next step is to divide your spectrum by the standard spectrum. 

Menu: Operation -> Divide one profile by another 

 

Your spectrum is the first profile, and the standard spectrum is the second profile. 

Now we need to smooth out the bumps and spikes. Only large scale features are part of the 

response profile. The smaller scale features are due to different resolutions and other small scale 

effects which cannot be corrected for. 

To make this process easier, we shall first remove and hide the other spectra. 

Remove the neon spectrum by selecting it, then right clicking and pressing Remove image. 

Remove the Pickles A0V spectrum by selecting it, then right clicking and pressing Remove image. 

Hide your image/spectrum by selecting it, then right clicking and pressing Hide Profile from Chart. 

  



39 
 

You should now only see the division profile as follows. 

 

Make sure the division profile is selected. 

We are now ready to create the smooth response curve. 

Menu: Tools -> Continuum Shaper 

Select the division profile as the target profile. 
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Then double click at points along the profile from left to right, skipping over troughs and peaks. 

 

You can correct any errors by double clicking a point for a second time to remove it. 

Now click save. There are several options here, I suggest save as a response DAT file in the folder 

where you are working, calling it something sensible. In this case I called it vega_response.dat. Then 

it is available to be used for all your spectra on that night. 

  



41 
 

Now double click your profile and select the Response tab. Then select the file you just created in 

the Response File box. 

 

Here is your response corrected spectrum. 

You can compare it to the Pickles A0V to check how well it has worked. You can use this knowledge 

to refine your technique. 
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7 - Crop Spectrum 

By default your spectrum will include regions which are not accurate due to the limitations of your 

telescope, spectrograph, detector and the atmosphere. Hence it is good practice to crop your 

spectrum to the wavelength region where you are confident in the processing. 

Menu: Chart -> Crop X-Axis range 

Manually populate the crop range. 
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8 - Saving Your Spectrum 

It is standard practice to save your finished spectrum as either a 1D fits file, or a 1D dat file. The 

spectrum is simply composed of wavelength and intensity values, so you do not need the 2D image 

of your spectrum once you have processed it. This will allow you to share your spectrum with others 

and to open it in other spectroscopy packages. 

Menu: File -> Save as 1D profile 
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9 - BeSS Settings / BAA 

Good quality spectrum files can be submitted to databases like the BAA, BeSS and ARAS. These all 

need spectra to be saved as files of the same format. This format is 1D fits files compliant with the 

BeSS standard, which basically means certain fits header fields are populated. BASS has a menu for 

populating these fields to make it straight forward to create compliant files. 

a. Working out the resolution 

Before proceeding you will need to know the resolution of your spectrum. The easiest way to 

calculate this is to open your wavelength calibrated neon spectrum. To measure the resolution click 

on the following menu item: 

Menu: Tools -> Measurements and Elements 

In the Measurement Options tick FWHM. This means full width at half maximum, a measure of a 

spectral line’s width. 

 

Choose a bright clean line near the middle of the neon spectrum. Press and drag the cursor from left 

to right across the spectral line. 
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Then look at the measurement results window. 

 

The FWHM gives you the numbers you need, they are the R value and the wavelength, so 554 and 

5852.2. 

 

  



46 
 

b. Populating the BeSS Settings 

Make sure your 1D spectrum file is selected then use the menu. 

Menu: Image -> BeSS Settings 

The first tab can be populated as follows with your details: 
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The next tab only needs the object name. Other detail can be useful but is not required for the BeSS, 

BAA or ARAS databases. 
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The 3rd tab needs the Acquisition Details. 

You can use the “Read from Profile” button to populate the calibration data. 

Then enter “Effective SRP” and “Resolution calculation wavelength” from the resolution calculation 

above. 
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The 4th tab called “Processing” can normally be populated as follows. 

Note that no heliocentric correction should be applied when submitting to databases unless this has 

been specifically requested. 

 

 

Press the “Validate BeSS” button. 

Assuming there are no problems indicated by the validation then press “Save FITs header”. The Save 

FITS header updates the 1D fits file so there is no need to resave the file. 

The BeSS settings window can now be closed. 

 

You can then submit this file to a database such as the BAA Spectroscopy Database, BeSS and ARAS. 

Note that not all databases are interested in all objects, for example BeSS is for Be and Herbig Ae/Be 

stars only. You should also ensure that your processed spectrum is of good quality. 
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10 - Creating .bass and .bun Files of your Session 

BASS has a very useful feature which allows you to create a Project or Bundle file containing all of 

your images, spectra and settings. The Bundle files are especially useful if something is going wrong 

with your reduction process, as it can be used to share your BASS session with other users so they 

can provide help. 

To save your BASS session: 

Menu: File -> Save Project 

 

This screen has the option to save as 2 files types: 

• .bass 

• .bun 

.bass 

This saves a project file for your session containing your settings and links to the images and 

spectrum profiles stored on your computer. So when you re-open a .bass file it will re-open all of the 

images and spectra from their original location on your computer. This is good for personal use as it 

does not duplicate the files, and any changes you make will update those same files 

.bun 

This creates a bundle file which contains all of your images and spectrum profiles in the .bun file, as 

well as all of your settings. When you open a .bun file it will extract the images and spectrum profiles 

into a new folder of your choosing. It is a good idea to save a .bass file before creating a .bun file. 
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To re-open a project: 

Menu: File -> Open Project 

 

The drop down in the bottom left allows you to choose between a Project (.bass) or a Bundle (.bun) 

file. 

If you select a Bundle file then it will ask you where you want to unpack the bundle. This will create 

copies of all of your images, spectra and settings in that folder. By default the folder will be the 

name of the bun file, but you can choose a different folder using the browse button. 
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Once unpacked, BASS will open all of the images and spectrum profiles from the new folder. So this 

will not link back to the original copies of your images and spectra. 

Below is an example of an unpacked Bundle. 

 

 


